Trying intranda opac json plugin, get xml error

Hi, I’m a goobi newbie, so excuse me if I’m just not getting everything yet.

After installing the plugin_intranda_opac_json and configuring goobi_opac.xml and plugin_intranda_opac_json.xml,
I get the same error whatever I enter in the later file.

In goobi_opac.xml, when I did not have a port number, I got an error, so then after correcting that, I presume goobi_opac.xml is correct.
But when I try to “Create process based on this process template” I get an xml error. It happens to be in Swedish, but translated it says:

XML interpretation error, no root element found
Address: ourserver/goobi/uui/process_all.xhtml
Row number 1, column 1:

I’d be happy to get some recommendations on what to test / do.

/ Maria

Hello again,
The error that I described above was fixed when we copied
Now I just have to configure the metadata. :slightly_smiling_face:

1 Like

Dear Maria,

welcome to the community. :slight_smile:

Can you please share the file and configuration that you tried at the beginning so that we can reproduce the error and solve the underlying issue as well. This would help yourself and future other users for the same use cases.

Thanks a lot in advance. All the best,


Hi Steffen,
Thanks :slightly_smiling_face:
It was not the xml files’ content that we used that caused the problem. It was a missing file in the installation.

In /var/lib/tomcat9/webapps/goobi/uii/
there was no file jsonOpacPlugin.xhtml

when we added that, it worked.

I’ll come back with a question about “Create new process”.

/ Maria


But how did you install the plug-in then? From where did you take it and how did you install it?

@robert.sehr do you have an idea what was missing here probably?


Hi Steffen,
My colleague installed it according to the documentation and this forum post

I now realize that at the beginning of the forum post, Stephen Gadd writes about the file jsonOpacPlugin.xhtml missing from the installation.

And while we are discussing it, there are still two quite important paragraphs in the documentation of the json opac plugin that are in German :grinning:

Kind regards,

Dear Maria,

thanks for the comment about the missing translation. I fixed that some minutes ago. :slight_smile:

Regarding the installation we tested the plugin installation again and cannot confirm the missing part as you describe it. So if you would like to provide some more details about how you actually compiled and installed the plugin we can go deeper into the details to understand your issue.

This is how we tested it:

git clone
cd goobi-plugin-opac-json 
cd goobi-plugin-opac-json
mvn package
cp module-gui/target/plugin_intranda_opac_json-GUI.jar /opt/digiverso/goobi/plugins/GUI 
cp module-main/target/plugin_intranda_opac_json.jar /opt/digiverso/goobi/plugins/opac
cp plugin_intranda_opac_json.xml /opt/digiverso/goobi/config

This should acutally be it. Can you please double check?

All the best,


Thanks for fixing the translation!

When you had run the steps in your example above, is this file in place afterwards:


/ Maria


When I do the copy command the *GUI.jar file (with the *.xhtml file in it) ends up in the GUI folder for the plugins. And it is read from there then. But it is important to restart the tomcat server after the GUI files with the user interface are installed.

I guess you forgot to do the restart in between probably.



Thanks for your help! It is possible that we forgot to restart, or some other problem.
Now it’s working, and the xml to get metadata from Libris is completed.