Widget "Suche" in Kombination mit Template und SOLR-Query

Liebe community,

wenn eine neue Seite im CMS angelegt wird, und man dafür zB das Template “Einzelansicht einer Sammlung” nutzt, funktioniert das Widget “Suche” für diese Seite im viewer scheinbar nicht?

Beispiel: Bibliothek Reinhold Köhler - Digitale Sammlungen der Herzogin Anna Amalia Bibliothek
Hier lautet die SOLR-Query: MD_HAAB_PROVENIENCE:‘Privatbibliothek AND Reinhold AND Köhler’

Nutze ich hier das Widget in der Sidebar für die Suche, sollte beim Suchbegriff “Buchfart” eigentlich genau ein Treffer ausgegeben werden. Angezeigt werden aber null Treffer.

@jan : Weisst Du, woran das liegt? Ich hatte ja anfangs die AND-Verknüpfung in Verdacht.

Beste Grüße, Andreas

Hi,

die Solr Query war falsch, ja.

Falsch:

MD_HAAB_PROVENIENCE:‘Privatbibliothek AND Reinhold AND Köhler’

Richtig:

MD_HAAB_PROVENIENCE:"Privatbibliothek Reinhold Köhler"

Ich habe mir erlaubt das für die CMS-Seite und auch das Suchen-Widget anzupassen. An dieser Stelle sei auch noch einmal auf den Anwendungsfall “Solr Queries” in der Dokumentation verwiesen:

LG Jan :slight_smile:

1 Like

Ahoi,

vielen Dank für den Hinweis und die Hilfe.

Eventuell noch eine Ergänzung zur Dokumentation (wenn meine folgende Aussage korrekt ist). Es kommt ja immer wieder vor, dass Signaturen Sonderzeichen enthalten (Beispiel: O 9 : 192). Für eine SOLR-Query ist das ungünstig, da Sonderzeichen wie + - && | | ! ( ) { } [ ] ^ " ~ * ? : \ nicht ohne weiteres eingebunden werden können. In solchen Fällen muss das entsprechende Sonderzeichen mittels eines vorangestellten \ gekennzeichnet werden.

Liebe Grüße, Andreas

Hallo Jan,

mit dem obigen Beispiel klappt es auch mit dem Suchen-Widget. Aber wie macht man das bei so einer SOLR-Query: +MD_HAAB_PROVENIENCE:“Gottsched” +MD_SHELFMARK:“O 9” ?

LG Andreas

Was funktioniert denn an der Query nicht?

Die SOLR-Query funktioniert, wenn es darum geht, diese Seite korrekt mit bespielen:
https://haab-digital.klassik-stiftung.de/viewer/dramensammlung_gottsched/

Das auf dieser CMS-Seite mit der identischen SOLR-Query angelegte Widget “Suche” funktioniert allerdings (zumindest bei mir) nicht. Unterscheidet sich die Formatierung der Query an den beiden Stellen?