Max Image Size (configuration error?)


A large image in Goobi workflow is giving me some trouble. When I run it in QA or in the metadata editor, I find that the tiled image doesn’t load. I can see that it’s hitting a 404 error, with the following message:

“Error initializing image resource for 9. Reason: Image size is larger than the allowed maximal size. Please consider using a compressed derivate or generating thumbnails for these images.”

However, I can’t quite figure out where to change the configuration to allow it through. The VM should be powerful enough to handle it (480MB).

I’ve attempted to change in “” but to no effect:

# The maximum image size in bytes, MaxImageFileSizeUnit must be set as factor

# The unit for the maximum image size in bytes, MaxImageFileSize must be set as numeric value

Is this not the correct configuration setting?



Hi John,

there is also another setting in “”:

#maximal image width or height
#Larger images are not loaded directly but may be view via thumbs

This is the maximum allowed size of the largest image egde. Maybe this is what prevents your image from loading? Otherwise your configuration looks correct and should load images of up to 6GB size.

Thank you, Florian, that worked perfectly.