Intranda_import_excel errors

Hi. I’ve found a couple of issues with this plugin and its documentation.

The configuration file is now called plugin_intranda_import_excel.xml, but the documentation still states:

Within that file, on my setup, if I set replaceExistingProcesses to true, I get this error:

Hope that’s helpful…

All the best,

… also, I cannot get the image import to work. Processes listed in my Excel file are otherwise imported successfully, all of the metadata are imported and assigned without any error report, but the images are not touched (with moveImages set either true or false). The metadata->process->images->master folders are empty, but the meta.xml files look OK. I’ve tried writing the absolute path in either the Excel file or in the imageFolderPath, and I have opened the permissions in the image folder, which contains only .jpg images with simple numeric names.

Perhaps this problem is linked to the one I reported in my previous message in this thread?

Best wishes,

I will update the documentation tomorrow. This will help for the future.

Regarding the images there was an update two days ago for that plugin to use the correct new master folder (we extended the folder default names shortly). Can you try that update maybe to see if that works now?


Hi, and thanks again, @steffen. Yes, I reinstalled it yesterday but saw no improvement unfortunately.

My filesystem and plugin_intranda_import_excel.xml look like this:

… and I’m importing a file in which a cell in a column headed Folder contains the value E190/905/6. Do I have all the right slashes in all the right places?

The folder structure resulting from the import is like this, without any images copied:


:face_with_monocle: I see that the generated meta.xml file includes a tag like this:

<goobi:metadata name=“pathimagefiles”>./images/</goobi:metadata>

Best wishes,

Hi @Stephen_Gadd, Did you find out about the image upload issue?

That is a good question. I just noticed that I never answered this one. So it would be good to hear what the status is.
@hemed Do you find any issue with your import? If so I would be glad to hear about it to clean up documentation if needed.


Ummm… sorry not to be more helpful: I had to leave my work on this unfinished (and that particular issue unresolved) but hope to come back to it one day!

Thank you for the reply @Stephen_Gadd . @steffen, I have not tried this yet but I am planning to do so. I will share here if I find any issue.